Ron & Doug's Sales Camp https://www.pressurecleaningschool.com/events/houston-sales-training-school/
Results 1 to 6 of 6
  1. #1
    Member Freshman Undergraduate trianglehomedeck's Avatar
    Join Date
    Apr 2017
    Location
    Durham
    Posts
    6

    Udor Pump Pressure Problem - Need Help

    I have a WATER DRAGON LOW PRESSUREAPPLICATOR SYSTEM 10.5 GPM @300PSI, ELECTRIC START HONDA,UDOR ZETA PUMP, 300' AG HOSE Soft Wash setup.

    I am only getting about 50psi pressure when I usually get upwards of 200.

    Here is the list of things I have done:

    - Rebuilt entire pump with all new diaphragms and check valves
    - Put all new oil in the pump
    - Checked every hose for leaks, I am not seeing any bubbles in the hose nor do the hoses shake abnormally when its running

    My Honda runs fine, and everything seems normal, except pressure is not there. I need help figuring out whats going on.

    Thanks for your time,

    Richard


    Richard Mounce
    Owner - Triangle Home & Deck
    919.525.3272
    www.trianglehomeanddeck.com

  • #2
    Member Junior Undergraduate NickGann's Avatar
    Join Date
    Jun 2011
    Location
    MURFREESBORO
    Posts
    259
    At the risk of insulting you, I would start with a basic... do you have it in prime position?

  • #3
    Member Freshman Undergraduate trianglehomedeck's Avatar
    Join Date
    Apr 2017
    Location
    Durham
    Posts
    6
    I am certainly not above making a stupid mistake, but I have been running it for 3 years, so like I said everything is normal (not in prime), I just don't have the full pressure.


    Richard Mounce
    Owner - Triangle Home & Deck
    919.525.3272
    www.trianglehomeanddeck.com

  • #4
    Member Junior Undergraduate NickGann's Avatar
    Join Date
    Jun 2011
    Location
    MURFREESBORO
    Posts
    259
    Then If everything is pumping fine and there is no air trapped, it's not in prime, and no leaks... I would bank on a bad unloader which is bypassing everything.

  • #5
    Member Junior Undergraduate NickGann's Avatar
    Join Date
    Jun 2011
    Location
    MURFREESBORO
    Posts
    259
    Another thought... make sure nothing is trapped in any of your ball valves if you are using them on the inlet side especially. If trash is keeping it from properly closing it might limit your suction and pressure.

  • #6
    Member Honorary Professor Sirocco Jerry's Avatar
    Join Date
    Oct 2009
    Location
    El Cajon, CA
    Posts
    1,078

    Diaphragm Pump Pressure Loss

    ..there's no mention of a Regulator rebuild..
    ..Is it Bypassing your pressure ??
    Call me if you're still down.
    ..and please Like my FaceBook pages.
    Jerry McMillen


    619-448-8111 ............800-400-2532
    www.PressureWasher.net e-e at.. Jerry@PressureWasher.net
    Sirocco Performance Vacuums, ..... the VacuBerm,
    and BullDogPro Industrial Water Blasters

    Our tools increase your profitability

  • Thread Information

    Users Browsing this Thread

    There are currently 1 users browsing this thread. (0 members and 1 guests)

    Bookmarks

    Bookmarks

    Posting Permissions

    • You may not post new threads
    • You may not post replies
    • You may not post attachments
    • You may not edit your posts
    •